Degraded Service: Cloudflare Network Performance Issues
Incident Report for Jane
Resolved
This incident has been resolved.
Posted Feb 15, 2022 - 23:54 UTC
Monitoring
Cloudflare, one of our cloud infrastructure service providers, is currently experiencing network performance issues on the West Coast: https://www.cloudflarestatus.com/. This is resulting in slow page loads. We will keep you updated as we get updates from Cloudflare.
Posted Feb 15, 2022 - 22:45 UTC
This incident affected: External Service Providers (Cloudflare).